注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

网事

备忘录

 
 
 

日志

 
 

APACHE 安装出错 configure: error: Cannot use an external APR with the bundled APR-util  

2012-03-12 21:54:05|  分类: apache |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

configure: error: Cannot use an external APR with the bundled APR-util
根据错误信息进行解决
安装apr和apr-util
http://apr.apache.org上面有这些源码包自己编译安装

tar xzvf apr-1.2.9.tar.gz
cd apr-1.2.9
./configure --prefix=/usr/local/apr
make
make install

tar xzvf apr-util-1.2.8.tar.gz
cd apr-util-1.2.8
./configure --prefix=/usr/local/apr-util --with-apr=/usr/local/apr
make
make install

接下来安装apache
./configure --prefix=/usr/local/apache2 --enable-so --enable-mods-shared=all --enable-cgi --enable-rewrite--enable-deflate --enable-headers --with-apr=/usr/local/apr --with-apr-util=/usr/local/apr-util --with-mpm=worker
make
make install
安装将不再出错

  评论这张
 
阅读(376)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018